View unanswered posts | View active topics It is currently Tue Feb 18, 2020 7:55 pm



Reply to topic  [ 14 posts ]  Go to page 1, 2  Next
 Patch updated 
Author Message
Site Admin
Site Admin

Joined: Thu Feb 07, 2013 11:16 am
Posts: 1855
Hello everyone,

The XStoryPlayer 3.5 patch 1 has been updated.
It now contains support for DirectX 11 (and also fixes some antialiasing issues).

DirectX 11 in itself does not change anything to the looks of the game.
It does mean a performance boost Graphics wise for most Graphics Cards.
It is a step up to allow integrating of latest Oculus Rift SDK (planned later) and the graphics layer for the new engine in general.

If you experience issues (or if things work better :) ) after installing this latest patch (3.5.0006) then please post them in this thread.

Best regards xpadmin


Fri Sep 11, 2015 9:13 pm
Profile
Rank 17
Rank 17

Joined: Fri Nov 21, 2014 10:37 pm
Posts: 526
It say i allready installed it when i check in account manager, should i redownload it?


Fri Sep 11, 2015 10:06 pm
Profile
Site Admin
Site Admin

Joined: Thu Feb 07, 2013 11:16 am
Posts: 1855
Yes re-download and then re-install.


Fri Sep 11, 2015 10:13 pm
Profile
Rank 3
Rank 3

Joined: Sun Sep 06, 2015 6:54 am
Posts: 8
1. just instaled new patch and game dont start. (XStoryPlayer64.exe disapear from folder)

edit2 added sys info
trace.txt
////////////////////////////////////////////////////////////
// X Moon Productions (c) 2012
////////////////////////////////////////////////////////////

Version: (3.5.0006)
Build: 64 bits
Release: Full
Date: 2015/09/12 02:58:11
.......................
OS: Microsoft Windows 7 Ultimate |C:\Windows|\Device\Harddisk0\Partition1
Cpu: Intel(R) Core(TM)2 Duo CPU E7300 @ 2.66GHz (My PC name: 3582 Mb)
Graphics-card: NVIDIA GeForce 9600 GT (512 Mb)
Sound-card: Realtek High Definition Audio
.......................

////////////////////////////////////////////////////////////
// Oculus Rift
////////////////////////////////////////////////////////////

Oculus Rift was not detected


ERROR: DirectX CreateDevice failed: CreateDevice: D3D11CreateDeviceAndSwapChain failed

2. proced with delete all and reinstall game & patch...
3. reinstalled apply new patch same error, and again "XStoryPlayer64.exe" disapear when apply patch
4. edited settings.ini to DIRECTX9 game run normaly


Last edited by Naphala on Sun Sep 13, 2015 1:05 am, edited 3 times in total.



Sat Sep 12, 2015 12:03 am
Profile
Site Admin
Site Admin

Joined: Thu Feb 07, 2013 11:16 am
Posts: 1855
@Naphala

Thanks for the feedback.

The system info would help to determine what the issue may be. So if you could add it that would be great (especially graphics card).

If the issue persists, set render mode back to OPENGL or DIRECTX9 in 'settings.ini'


Sat Sep 12, 2015 12:13 am
Profile
Rank 18
Rank 18

Joined: Sun Jun 22, 2014 3:46 pm
Posts: 1095
@xpadmin thanks :D


Sat Sep 12, 2015 5:53 am
Profile
Rank 8
Rank 8

Joined: Mon Aug 10, 2015 12:28 pm
Posts: 40
I've found this issue in the love party mod after switching to dx11, btw there is a 5fps increase (with my crappy hd 5700)


Attachments:
Demo.png
Demo.png [ 2.58 MiB | Viewed 14463 times ]
Sat Sep 12, 2015 9:20 am
Profile
Rank 16
Rank 16
User avatar

Joined: Sat Aug 23, 2014 12:47 am
Posts: 348
games running great, definitely a slight but noticeable improvement on my system.

APU A8-3520M Quad Core 1.6ghz

Radeon HD 6620G 512VRAM (playing in DX11)

8GB ddr3 @1333mhz

64bit win 7 ultimate

especially noticeable with the fluids. before if i were to jizz the cpu usage would blow it's load as well, now it only goes up to 75%.


Sat Sep 12, 2015 10:54 am
Profile
Site Admin
Site Admin

Joined: Thu Feb 07, 2013 11:16 am
Posts: 1855
@alex88

This issue should be fixed now. Please re-download and re-install.

:)


Sat Sep 12, 2015 12:07 pm
Profile
Rank 3
Rank 3

Joined: Sun Sep 06, 2015 6:54 am
Posts: 8
this new patch give me headache :x

5. filemaker dont start and give this error in "fm_trace.txt"
ERROR: DirectX CreateDevice failed: CreateDevice: D3D11CreateDeviceAndSwapChain failed
//settings.ini is edited for DIRECTX9

can we have please the old patch in account manager ?


Sat Sep 12, 2015 6:25 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 14 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group.
Designed by X-Moon Productions.